Logiciel de dessin DenisDraw, illustration navire
Logiciel de dessin DenisDraw, illustration plongeur
  • Bienvenue !

Le fichier d'initialisation

Description du fichier : Denis?.ini* indiquant à Denis-draw des éléments de configuration par défaut.
Ce fichier peut être modifié à l'aide du bloc-notes il se trouve dans le répertoire C:\Windows
RubriqueOptions
avec la valeur par défaut
Commentaire
Modifier par le dialogue
[Denis]Coordonnées=OuiIndique si Oui ou Non les coordonnées de la souris sont affichées sur la ligne de statut.Préférence
[Denis]Compression=NonIndique si Oui ou Non les fichiers sont enregistrés en mode compressé (fichiers moins volumineux mais temps de chargement accru).Préférence
[Denis]Bitmap=OuiIndique si Oui ou Non Denis place dans le Presse-papiers une version bitmap des éléments copiés ou coupés.Préférence
[Denis]Image=OuiIndique si Oui ou Non Denis place dans le Presse-papiers une version vectorielle des éléments copiés ou coupés.Préférence
[Denis]Palette=NonIndique si Oui ou Non la palette flottante des couleurs est affichée au lancement de Denis.Préférence
[Denis]Secours=OuiIndique si Oui ou Non Denis enregistre en plus d'un document Denis (portant l'extension '.Teo') une copie de secours (portant l'extension '.Tbk') correspondant à la précédente version du document.Préférence
[Denis]Sélecteurs31=OuiIndique si Oui ou Non Denis utilise pour ouvrir ou enregistrer un fichier les sélecteurs de fichiers standards Windows 3.1.Préférence
[Denis]Point Contrôle en couleur=OuiAffiche les points de contrôle de chemin de dessin avec des couleurs différentes selon leur type:

logiciel dessinpoints de ligne en bleu
logiciel dessinpoints d'arc en vert
logiciel dessinpoints de spline en rouge

cf: les symboles d'affichages

Préférence
[Denis]Dégrader rapide=OuiIndique si Oui ou Non Denis affiche les dégradés en mode rapide, avec un nombre de bandes limité. Cette option n'affecte pas la qualité d'impression des dégradés qui conservent alors les attributs de la boîte de dialogue Dégradés.Préférence
[Denis]Déplacer forme pleine=OuiLe contour des éléments de dessin est visible pendant les déplacements en temps réel.Préférence
[Denis]Sauver metafile=NonIndique si Oui ou Non Denis enregistre le document en cours dans un fichier au format Metafile (.WMF) en même temps que le fichier Denis habituel (.TEO) quand on active les commandes Enregistrer ou Enregistrer sous... du menu Fichier.Préférence
[Denis]Palette couleur=OuiIndique si Oui ou Non Denis enregistre la palette de couleur avec le document.Préférence
[Denis]Règles=OuiIndique si Oui ou Non les règles sont affichées.Préférence
[Denis]Unité des Coordonné=2avec les valeurs 0:centimètre, 1:mètre, 2:pouce.Bouton dans les règles.
[Denis]Nombre d'annuler=2Fixe le nombre d'annuler à 2 (valeurs possibles: 0 à 30).Préférence
[Denis]Règles Pouce=NonIndique si Oui ou Non l'unité des règles est le pouce (sinon le mm).Préférence
[Denis]Grille Pouce=NonIndique si Oui ou Non l'unité des grilles est le pouce (sinon le mm).Préférence
[Denis]Palette 256=NonIndique si Oui ou Non Denis gère une palette de couleurs pures.Préférence
[Denis]Palette Fixe=OuiIndique si Oui ou Non la palette fixe est affichée au lancement de Denis.Préférence
[Denis]Info Bulles=NonIndique si Oui ou Non les Infobulles sont actives.Préférence
[Denis]Barres d'icônes activées=OuiIndique si Oui ou Nom les Barres d'icônes sont affichées (mis à jour en activant l'option Actif de la boîte de dialogue Configurer les Barres d'icônes.Préférence
[Denis]Bord bleu=OuiIndique si Oui ou Nom Denis affiche un cadre bleu autour du document (option Bord bleu de la boîte de dialogue Préférences).Préférence
[Denis]Progression=OuiIndique si Oui ou Nom Denis affiche des barres de progression en bas de l'écran (option Barre de progression de la boîte de dialogue Préférences).Préférence
[Denis]Palette Large=OuiIndique si Oui ou Nom Denis affiche une grande palette de couleurs (option Palette large de la boîte de dialogue Préférences).Préférence
[Denis]Grands outils=OuiIndique si Oui ou Nom Denis affiche une grande boîte à outils (option Grands outils de la boîte de dialogue Préférences).Préférence
[Denis]Petit Point Ctrl=OuiIndique si Oui ou Nom les objets à l'intérieur d'un groupe afichent des petits points à leurs extrémités (option Petit pts de Crl de la boîte de dialogue Préférences)Préférence
[Denis]Avec Rectangle=NonIndique si Oui ou Nom chaque objet affiche un rectangle quand on déplace la sélection (option Avec rect.de la boîte de dialogue Préférences)Préférence
[Denis]Grand icône=NonIndique si Oui ou Nom les barres d'icônes sont affichées avec de gros icônes (option Grand rect. de la boîte de dialogue Configurer les Barres d'icônes).Préférence
[Denis]Cadre des textes=NonIndique si Oui ou Nom un rectangle est affiché autour des blocs de texte Windows quand ils ne sont pas sélectionnés (si Non les rectangles ne sont pas affichés).Préférence
[Denis]Gabarits Actif=NonIndique si Oui ou Nom la boîte de dialogue Gabarits est affichée à l'ouverture de Denis.Préférence
[Denis]Gabarits=OuiIndique si Oui ou Nom la case à cocher Voir le Gabarit est cochée (boîte de dialogue Gabarits).Préférence
[Denis]Show Splah=OuiComme dénommé par les anglo-saxons, indique si l'écran de présentation s'affiche.Préférence.
[Denis]Affichage progressifIndique si le dessin est affiché au fur et à mesure, sinon s'il se construit dans un cache.Préférence.
[Répertoire]Fontes=C:\DenisIndique le répertoire ou se trouvent les fontes Denis (extension:'.fw).
[Répertoire]Help=C:\DenisIndique le répertoire ou se trouve le fichier de l'aide de Denis: Denis.hlp.
[Répertoire]Teo=C:\Denis\TEOIndique le répertoire de travail, là où sont placés les documents Denis: nom_de_fichier.teo.
[Répertoire]Dc=C:\Denis\DCIndique le répertoire de base du dictionnaire, répertoire devant contenir le fichier DC.DC et le sous-répertoire TEO.
[Répertoire]BMP=C:\Denis\BITMAPIndique le répertoire par défaut de chargement et de sauvegarde des fichiers bitmap portant l'extension '.BMP'.
[Répertoire]PLT=C:\Denis\PLTIndique le répertoire par défaut de chargement et de sauvegarde des fichiers HPGL (*.PLT).
[Répertoire]PS=C:\Denis\FLASHIndique le répertoire par défaut de sauvegarde des fichiers Postscript (*.PS).
[Répertoire]TXT=C:\DenisIndique le répertoire par défaut de chargement et de sauvegarde des fichiers Script (*.TXT).
[Répertoire]WMF=C:\DenisIndique le répertoire par défaut de chargement et de sauvegarde des fichiers Metafile (*.WMF).
[Répertoire]TGA=C:\DenisIndique le répertoire par défaut de chargement des fichiers bitmap portant l'extension '.TGA'.
[Répertoire]PCX=C:\DenisIndique le répertoire par défaut de chargement des fichiers bitmap portant l'extension '.PCX.'.
[Répertoire]DXF=C:\Denis\DXFIndique le répertoire par défaut de chargement des fichiers portant l'extension '.DXF'.
[Répertoire]GAB=C:\Denis\GABARITSIndique le répertoire par défaut de chargement des fichiers Denis à ajouter dans la liste des gabarits de la boîte de dialogue Gabarits..
[Répertoire]Recherche=C:\DenisIndique le répertoire où a été effectuée la dernière recherche de fichiers avec la commande Trouver/Références.
RubriqueOptions
avec la valeur par défaut
Commentaire
Modifier par le dialogue
[Grille]Visible=OuiIndique si Oui ou Non la Grille d'affichage est visible.Grille
[Grille]Actif=NonIndique si Oui ou Non la Grille magnétique est active.Grille
[Grille]Pas visible X=10Indique le pas en X de la Grille d'affichage.Grille
[Grille]Pas visible Y=10Indique le pas en Y de la Grille d'affichage.Grille
[Grille]Pas magnétique X=10Indique le pas en X de la Grille magnétique.Grille
[Grille]Pas magnétique Y=10Indique le pas en Y de la Grille magnétique.Grille
RubriqueCommentaire
[Program]Pour démarrer d'autres programmes depuis le menu Options. //Exemple:
1=&Drive Surface..., c:\windows\Denis\Bzsurfac.exe
2=&Presse Papier..., c:\windows\Clipbrd.exe
3=&NotePad..., c:\windows\Notepad.exe
4=&Denis.Ini..., c:\windows\Notepad.exe c:\windows\Denis.ini
Modifier par un editeur de texte dans le fichier Denis3.ini
RubriqueIndicesCommentaire
[Fichiers]NB=6Indique le nombre de fichiers rappelés dans le menu Fichier.
[Fichiers]Max=6Indique le nombre maximum de fichiers pouvant être rappelés dans le menu Fichier.
[Fichiers]1=c:\Denis\demos\bip.teo
[Fichiers]2=c:\Denis\etiquette\etiq_4d5.teo
Modifier par les ouvertures succésives du dialogue ouvrir du menu fichier.
RubriqueIndicesCommentaire
[Config Page]Sauvegarde les paramètres de la boîte de dialogue Configurer la page.
[Config Page]Taille=2


Le format de la page est A4.
Peut prendre les valeurs suivantes:
1 - A5: 148 X 210
2 - A4: 210 X 297
3 - A3: 297 X 420
4 - B5: 182 X 257
5 - B4: 250 X 353
6 - Tabloïde: 279,4 X 431,8
7 - Lettre US: 215,9 X 279,4
8 - Legal US: 215,9 X 355,6

Configurer la page
[Config Page]Orientation=1L'orientation est Portrait.Configurer la page.
[Config Page]Orientation=2L'orientation est Paysage.Configurer la page.
[Config Page]Couleur=16777215Indique la couleur du papier en décimal codé sur 16 bits.Configurer la page.
[Config Page]Autre X=210Indique la dimension de la page horizontal en mm.Configurer la page
[Config Page]Autre Y=297Indique la dimension de la page vertical en mm.Configurer la page
Modifier par la boîte de dialogue Configurer la page
Configurer la page
RubriqueIndicesCommentaire
Configure le sous-menu appelé par la commande Editer Bitmap du menu Popup quand une image par point est sélectionnée ou le bouton Editer du dialogue information.
[Bitmap]Nb=2Indique le nombre de programmes de retouche d'image trouvé dans la base de registre.
[Bitmap]1=PBRUSH.EXEIndique le nom du premier programme pour ouvrir le logiciel paintbrush de Microsofttm
[Bitmap]2=c:\windows\graphy\psp\psp.exePour ouvrir le logiciel Paint shop-Pro.
Cette section est crée automatiquement au lancement de Denis-draw qui recherche les application qui ouvre les fichiers images (exemple .jpg) dans la base de registre.
RubriqueIndicesCommentaire
[Ligne]Sauvegarde les paramètres de la boîte de dialogue Epaisseur de ligne accessible depuis la boîte de dialogue Préférences.
[Ligne]1=1Indique l'épaisseur du premier bouton ligne en dixième de millimètre.
[Ligne]C1=00000000Indique la couleur du premier bouton en Hexadécial (00BBVVRR).
[Ligne]2=5Indique l'épaisseur du deuxième bouton ligne en dixième de millimètre.
[Ligne]C2=00FF0000Indique la couleur du deuxième bouton en Hexadécial (00BBVVRR).
[Ligne]3=10Indique l'épaisseur du troisième bouton ligne en dixième de millimètre.
[Ligne]C3=000000FFIndique la couleur du troisième bouton en Hexadécial (00BBVVRR).
[Ligne]4=15Indique l'épaisseur du quatrième bouton ligne en dixième de millimètre.
[Ligne]C4=0000FF00Indique la couleur du quatrième bouton en Hexadécial (00BBVVRR).
Modifier par la boîte de dialogue Preférence
RubriqueIndicesCommentaire
[Gabarits]NB=4Indique le nombre de fichiers Denis affichés dans la liste des gabarits de la boîte de dialogue Gabarits.
[Gabarits]Max=6indique le nombre maximum de fichiers Denis que vous souhaitez voir figurer dans la liste des gabarits de la boîte de dialogue Gabarits.
[Gabarits]1=C:\Denis\demo\bulletin.teoChaque chemin et nom des fichiers qui apparaissent dans le dialogue gabarit.
[Gabarits]2=C:\Denis\demo\beacholy.teo""""
[Gabarits]3=C:\Denis\demo\sophie.teo""""
[Gabarits]4=C:\Denis\demo\victori.teo""""
[Gabarits]lauch=#Si lauch est différent du caractère # et représente une ligne de commmande alors ouvrir ce gabarit pendant l'initialisation au démarrage left ou right indique la position de la fenêtre de ce gabarit avec l'espace à occuper en pourcentage. Exemple lauch=c:\exe\Denis\demo\escargot.teo %left=40
Modifié par la boîte de dialogue Gabarit du menu fichier
[gradient]indice=nombre de gradient.
indice-sous-indice=La valeur Rouge Vert Bleu, le signe égal détermine sa position entre 0 et mille.
Une liste dynamique de dégradé pour le ruban qui s'ajoute a ceux prédéfinies.
Modifié par la boîte de dialogue Dégradé du menu Attributs
[circle]progress=NonDétermine dans les préférence un affichage progressif ou un affichage dans un cache.
[circle]crenelage=NonDétermine dans les préférence si l'affichage utilise GDI ou GDI+Plus.
[circle]window_left=21La position gauche de la fenêtre quand elle doit s'ouvrir avec la même taille.
[circle]window_right=881La position droite de la fenêtre quand elle doit s'ouvrir avec la même taille.
[circle]window_top=222La position haute de la fenêtre quand elle doit s'ouvrir avec la même taille.
[circle]window_bottom=734La position basse de la fenêtre quand elle doit s'ouvrir avec la même taille.
[circle]Taille de la fenêtre=Telle quelleLa taille de la fenêtre quand elle doit s'ouvrir à nouveau.
[circle]jpeg=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier jpeg.
[circle]dxf=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier dxf.
[circle]eps=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier eps.
[circle]svg=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier svg.
[circle]vml=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier vml.
[circle]xml=C:\exe\DenisLe chemin correspondant à l'écriture d'un fichier xml.
[circle]color_balise_the_filling=16711680La couleur des balises lors de l'import d'un fichier xml.
[circle]color_balise_the_border=128La couleur de la bordure des balises lors de l'import d'un fichier xml.
[circle]color_libeller_indent=16711680La couleur des libellés indentés lors de l'import d'un fichier xml.
[circle]color_libeller_string=0La couleur des libellés lors de l'import d'un fichier xml.
[circle]color_comment_string=65280La couleur des commentaires lors de l'import d'un fichier xml.
[circle]radio_xml=xml_do_not_show_caseAu choix une de ces propositions :
  • xml_do_not_show_case
  • xml_show_case
  • xml_gradient
[circle]font_xml_typo_name=ArialLe nom de la typographie utilisée lors de l'import d'un fichier xml.
[circle]font_xml_typo_size=4La taille de la typographie utilisée lors de l'import d'un fichier xml.
Modifié par les options des préférences de la prévisualisation.

logiciel dessin


Note* : le caractère ? pour indiquer un seul caractère en l'occurance 3 pour cette version.