Logiciel de dessin DenisDraw Logiciel de dessin DenisDraw Logiciel de dessin DenisDraw Logiciel de dessin DenisDraw
  • Bienvenue !

logiciel dessin Nouveautés

  • Dans la prévisualisation, un éditeur de propriété permet de personnaliser les paramètres des effets, des déformations et des cotations ainsi que des projections avec un affichage instantané des modifications.
  • Dans la prévisualisation, une fenêtre de visualisation en trois dimensions si vous avez parametré les altitudes des calques avec OpenGl.
  • Dans le menu effet sur les lignes, une entrée du menu Épaisseur de contour à zéro pour affecter une épaisseur de contour à zéro aux éléments sélectionnés en parcourant aussi les éléments groupés.
  • Une petite fenêtre dans la palette des couleurs pour afficher le nom de la couleur survolée.
  • Une nouvelle commande du ruban dynamique « Revenir d'un élément » si vous avez affecté le nombre des annulés à zéro dans les préférences pour ne plus afficher de barre de progression pendant l'utilisation de Denis-draw, alors ce bouton permet d'effacer le dernier dessin affiché, et si celui-ci était sélectionné, l'élément précédant le devient aussi.
  • Enregistrement dans le fichier d'initialisation: Denis3.ini de l'affichage ou pas de la console de la prévisualisation.
  • La dll Vic-pilot exporte un fichier ATO vers la prévisualisation avec la commande Open_Vue.
  • Un plug_ins (greffon) dans le menu Extension pour parcourir le disque et afficher tous les fichiers .téo.
  • Exportation vers processing avec la prévisualisation, chaque calque (layer) est exporté séparément pour faire une animation il suffit de les afficher en boucle.
  • Les images bitmaps exportées dans le fichier ATO, pour la prévisualisation ou l'impression 32-bits, sont des fichiers temporaires mais si vous utilisez la commande exporter du menu fichier ils sont enregistrés comme des fichiers ordinaires qui utilisent le nom du fichier dans le même répertoire et un numéro incrémental.
  • Une fonctions du menu fichier de la prévisualisation permet de renvoyer le document vers denis-draw en utilisant la bibliothèque Vic-pilot.
  • Des ascenseurs dans la prévisualisation ; si vous zoomez sur votre document la première version affichait une partie du document, avec les ascenseurs vous pouvez vous déplacer sur la page, la partie visible correspondant à une proportion des rectangles de déplacement.
  • Un menu pop-up, sur la case des boutons obligations, qui s'affiche quand l'outil ligne est sélectionné. Pour contraindre le dessin par pas de 15°, 30°, 45°, 60°, 90°.
  • Si deux lignes sont sélectionnées, un bouton connecteur s'ajoute dans le ruban dynamique, et un menu pop-up apparaît pour dessiner à l'internav des deux lignes, un connecteur rond selon trois taille : fin, moyen, large ou un espace blanc pour indiquer que les lignes ne sont pas connectées ou un pont pour indiquer le passage d'un fil au dessus de l'autre.
  • Le dessin de ligne avec un « style »; pour dessiner des lignes avec des tirets, cette fonction du gdi était trop fine et pour la résolution des imprimantes elle ne tenait pas compte non plus, de l'épaisseur des lignes, réglable.
  • logiciel dessin
  • Une palette de composants électroniques dans le dialogue organigramme
  • Le calcul d'interpoline avec des courbes splines ou des éléments de texte.
  • Amélioration de l'export dxf : ajout du code de couleur des surfaces pleines et du style des lignes (tireté...). Testé avec QCad.
  • Un greffon de dessin, ou l'on place des points pour obtenir une surface colorée par interpolation. Le télécharger.
  • Modification du dessin des flèches de cotation avec les arcs de cercles les flèches aux extrémités suivent la courbe.
  • Utilisation concluante de Denis-draw avec les plotters de tracé et de découpe Graphtec. Seul l'installation préalable du driver correspondant au modèle du traceur est requis.
  • Affichage du relief, une autre modification pour afficher celui-ci comme une transition du chemin suivant la direction déterminée.
  • Une petite modification dans le dialogue d'affichage des préférences pour choisir si l'affichage est progressif, c'est à dire dessiné directement dans la fenêtre de dessin au fûr et à mesure ou bien dans le cas contraire dessiné dans un cache une fois l'intégralité du dessin terminé. Dans un cas l'affichage se construit visuellement, dans l'autre le dessin est obtenu d'un coup pour être plaqué à l'écran.
  • Dans le menu guide, une entrée de plus pour ajouter des pictogrammes nids d'hirondelles logiciel dessin ainsi dénommé par les imprimeurs sur les points de contrôle du chemin sélectionnée.
  • Une sélection de « gradientts » prédéfinis, qui s'ajoute dans le ruban dynamique, cette liste peut aussi afficher vos propres mélanges de couleurs synthétiques avec le bouton ajouter du dialogue dégradé. Comme l'utilisation du dialogue dégrader devient superflue, deux autres boutons dans ce même ruban pour définir l'angle en degré et un pas variable selon quatre étapes : Fin, Moyen, Large, Épais. Si aucun éléments de dessin n'est sélectionné alors le menu gradient ajoute un rectangle sur la page.
  • Le dessin de ruban avec un dialogue de paramètrage (épaisseur de celui-ci) proportionnelle au dessin - choix des couleurs intermédiaires.
  • Effet sur les splines des épines ou des losanges, et l'export de ceux-ci dans Persistence of Vision Raytrace pour réaliser un bandeau animé.
  • Un dialogue de retouche colorimétrique des trois canaux primaires avec des courbes de réglage indépendantes.
  • Dialogue gabarits, ouverture d'un de ceux-ci automatiquement au lancement pour l'afficher dans un panneau dont la position est au choix droite/gauche/haut/bas sa taille est aussi ajustable dans le fichier d'initialisation mais aussi dans le dialogue gabarit.
  • Des boutons avec le chemin dans le dialogue d'ouverture des fichiers style linux.
  • Enregistrement de la position de la fenêtre des outils.
  • Un menu pop-up dans le menu fichier nouvelle page avec des valeurs prédéfinies ou réglables du format de la page (A4,A5...).
  • Les effets sur les splines dans le ruban dynamique.
  • Interface, des boutons avec le style aquatique du macintosh.
  • Des fonctions supplémentaires dans la prévisualisation pour écrire en JPEG, Vml pour Ms-Office s'il est installé, Svg pour Inkscape.
  • logiciel dessin  Une réglette qui s'affiche par dessus le document, pour faire des mesures, qui tourne sur elle même avec la molette et les touches Ctrl et Maj, les touches directionnelles et aussi +/-. Les couleurs de la réglette peuvent être modifiées dans les préférences de ligne. Quand la réglette est active une entrée du menu pop-up permet de l'insérer comme un élément de dessin.
  • Un greffon d'affichage des statistiques horaire d'utilisation de Denis-draw. A chaque ouverture du programme l'indice correspondant à l'heure de lancement augmente de un dans la nav [Time] de Denis?.ini. Ce greffon permet d'afficher le diagramme correspondant avec quelques paramètres.
  • Un greffon pour simuler l'affichage d'un spot comme un dégradé conique avec trois couleurs.
  • Un nouveau menu Extension pour répertorier les greffons qui s'ajoute à l'application.
  • Des textures avec un dialogue de visualisation-sélection de celles-ci.
  • Des mini-pictogrammes associés aux éléments de menu en option dans le dialogue préférence.
  • Si vous survolez avec le curseur de la souris les différentes palettes un algorithme retrouve le nom de chacune de ces couleurs.
  • Un mini-langage de script Vic-Pilot inclu dans une Dynamic-Link-Library, exemple du prototype d'appel des fonctions dans trois formulations informatiques (BASIC, Delphi, Visual C).
  • Construire un organigramme avec quelques boutons de positionnement.
  • Une autre option dans le paramètrage de l'outil ligne:
  • Commande dessiner une flèche dynamiquement avec la commande Flécher du menu effet.
  • Amélioration du dessin des bordures-laser avec la possibilité de choisir des couleurs intermédiaires dans le dialogue attributs de dessin.
  • Modification de la commande assembler pour tenir compte des éléments de dessin ouverts, s'il est possible de les remplir cette commande s'ajoute aussi dans le menu pop-up.
  • Ajout de la fonction remplissage (floodfill en Anglais) dans les options du paramètrage de l'outil cercle.
  • Des fonctions supplémentaires dans l'export persitence ray-trace:
  • Une option du dialogue de dessin des lignes pour dessiner des escaliers (cf son code-source).
  • Pour plus de finesse des mini-guides logiciel dessin dans le sous-menu Guide du menu Options et des guides non-orthogonaux (inclinés) à placer avec le bouton-droit de la souris de la case Origine (a l'internav des règles). La possibilité de les afficher avant ou après le tracé avec la commande guide dessous.
  • Dans le menu Effets, une entrée spécifique au(x) cercle(s).
  • Si une trame est sélectionnée, un bouton du ruban dynamique « Autre » affiche un menu avec les options suivantes : Wriked - Léopard - Mouchetage - Damier - Bandeau - Aréosol (Spray).
  • Trois options de plus pour continuer les chemins de dessin automatiquement en symétrie dans le menu Effets. Commencer un chemin de dessin puis Activer une de ces trois commandes, ajouter ou déplacer des points de contrôle de chemin à celui sélectionné, visualiser le contour en temps réel.
  • Si deux cercles sont sélectionnés (et pas des ellipses) la commande engrenage s'ajoute dans le menu pop-up le centre de l'engrenage et celui du premier cercle dessiné. Le rayon intérieur celui du rayon du cercle le plus petit, le rayon extérieur celui du cercle le plus grand. Deux options, le nombre de dents et la forme des dents déterminer par des points de dessin de spline cubique ou de courbe de Bézier.
  • Ajout d'une option dans les paramètres de l'outil cercle qui permet de dessiner des cibles, le sigle danger-radiation ou une hélice avec un nombre de secteurs à déterminer - il est possible de faire tourner cette hélice avec l'outil rotation.
  • Activation des effets Ombre Relief Lumière dans la fenêtre d'affichage des objets.
  • Ajustement de la barre de progression avec affichage les pics d'utilisation.
  • Réglage de la lumière ou de la saturation dans le menu effets.
  • Un menu avec des fonctions mathématiques
  • Si vous cliquez avec le bouton droit de la souris sur le pictogramme de l'outil flèche, un menu pop-up, s'affiche pour faire des recherches multi-calques par exemple.
  • Une option de plus dans le ruban dynamique, si un cercle est sélectionné, alors vous pouvez ajouter son rayon, avec les pastilles le déplacer, tourner autour du centre.
  • Une fonction nommée Inter-Angle pour calculer des effet de contours.
  • Affichage d'un timer en seconde et centième de seconde xx'yy'' dans la barre de progression en bas de l'écran pendant les opérations lentes.
  • De nouvelles options dans les préférence pour valider ou pas l'affichage des symboles de positionnements et les pastilles. On les retrouve aussi dans la palette des outils avec ce symbole logiciel dessin mais ne sont pas permanentes dans ce cas.
  • Nouveau dialogue hachures.
  • Ajout dans la ligne de status, de l'affichage de la description des boutons de la palette couleur comme CIE.
  • Âpres la création d'une cotation, si elle est sélectionnée ces logiciel dessin deux boutons de la palette outils apparaisent dans ce cas pour modifier la taille des extrémités en forme de flèches.
  • Afficher ou pas le splash screen : (l'écran de présentation) dans le dialogue du menu Options / préférences.
  • Ajout du dessin d'une bissectrice dans le menu Effets / Sur les lignes.
  • Modification du dialogue information pour afficher les angles si deux segments consécutifs sont sélectionnés et la locution « angles plats » quand l'angle fait 180°.
  • Dessin de chanfrein sur des rectangles ou des polygones dans le menu Effet / Sur des polygones. Chainfrinage fonctionne aussi avec les ellipses même évidés.
  • Bascule automatique du mode « contour » - « couleur » pendant la peinture, identique à la touche de raccourcis '.'.
  • Dénomination des noms des différents polygones avec leurs racines grec dans le dialogue de paramètrage de l'outil polygone.
  • Actualisation du ruban pendant l'utilisation du logomètre, contrôle de la distance à dessiner est différente de 0 (zéro).
  • Dessin d'une réglette avec une commande du ruban dynamique, si un segment de droite est sélectionné avec un pas d'affichage des millimètres quand le zoom est assez précis.
  • Si vous dessinez une ligne et sélectionner l'outil flèche, des pictogrammes s'affichent sur la ligne. Pour utiliser ces fonctions, déplacer la souris sur un des pictogrammes puis cliquer et déplacer la souris.
  • Ces nouvelles commandes supplémentaires du menu pop-up si plusieurs calques sont créés :
  • Ajoute à la précédente version des cotations sur les arcs avec un déplacement longitudinal (sur la longueur).
  • Curseur de positionnement si la grille magnétique est activée, plus de fluidité dans le déplacement des curseurs avec la fonction SetClassWord.
  • Un visualisateur externe, qui utilise le moteur de dessin de Denis-Draw mais compilé en 32 bits avec Borland Delphi, pour tester, ce moteur et permettre d'ouvrir le format ATO, (la version ASCII du format des fichiers de ce logiciel). Ce visualisateur, serait aussi distribuable indépendamment, et pour l'instant il se compose des fonctions suivantes : lecture des fichiers ASCII théo file, visualisation dans une fenêtre avec un zoom et des ascenseurs. Affichage d'une liste arborescente du document avec une décomposition des calques (qui peuvent être visibles ou cachés), groupes énumérés, dessin avec ses attributs couleurs (modifiable), ainsi qu'une itération de chaque élément de dessin. Ce visualisateur permet aussi de copier l'affichage dans le presse-papier à la résolution d'affichage (zoom). Et aussi de convertir le document au format JPEG, tout ceci apporte des nouvelles fonctions au logiciel Denis-Draw, et ceci en utilisant aussi la bibliothèque du compilateur delphi 7, édition Studio.
        (cf) les nouvelles options des préférences.
  • Une fonction aléatoire pour dessiner ceci par-exemple ou ceci avec l'effet précédant.
  • Pour créer un effet avec des rayons: si une ligne et une spline ou deux splines sont sélectionnées, cette fonction les relie avec des rayons.
  • Pour ajouter des cotations à la souris sélectionner un segment et déplacer la pastille jaune ; fonctionne aussi sur les cercles avec une mesure du diamètre interne ou externe selon la position de la souris (ajout du symbole phi (ø) sur les diamètres), et aussi sur les arcs...
  • Ceci me donne aussi l'idée d'ajouter la sélection des cotations dans le menu édition/sélectionner comme, pour aussi ajuster l'échelle sur un groupe de cotation... et c'est fait.
  • Sélection des cotations dans le dialogue sélectionner-comme du menu Édition: pratique pour modifier l'échelle qui paraît alors dans le ruban dynamique.
  • Répartir sur des calques : une commande du menu-popup pour distribuer autant d'éléments qu'il y en a dans la sélection du calque actif vers autant de nouveaux calques.
  • Un nouveau jeu de caractères intégré est presque terminé - pour l'utiliser, un double-clic avec l'outil texte ouvre un éditeur de ligne, ce module génère des suites de segments formatés comme des éléments de dessin.
  • Envoi d'un message de terminaison, à openlong.exe (qui bloque la procédure de désinstallation) à la clôture de l'application.
    Version 4.31 Presque Portable Distribuée avec le magazine PC-Compatible en avril 2007. Elle se compose de 132.000 lignes ou encore 4 millions de caractères.
  • Nouvelle fonction pour simuler des effets voilés avec un segment de droite et une courbe spline.
  • Positionnement du satellite lune avec la souris dans un dialogue avec une zone d'affichage.
  • Création de ligne en appelant le logomètre avec un double-clic sur l'espace de travail quand l'outil ligne est sélectionné.
  • Nouveau export intégré de conversion pour Microsoft Expression Blend xaml.
  • Nouveau export intégré de conversion pour Persistence of Vision Raytracer.
  • Mise dans une image-cache du dessin des dégradés, l'affichage ne produit plus de recouvrement.
  • Reconnaissance des extrémités des segments pendant le dessin ce qui permet une aimantation du curseur sur ceux-ci.
  • Pictogrammes sur les figures de la documentation.
  • Export en VML des trames obtenue à partir des images par points.
  • Retouche du calcul et dessin pendant les déplacements des angles.
  • Affichage d'un « digital différences » des splines dans le menu effet.
  • Insertion dans le menu popup des fonctions copier-coller.
  • Une option du dialogue grille: la grille affichée par des lignes.
  • La touche '!' égal aux touches tabulation plus zoom sur objets.
  • Les touches '.' et '$' zoom sur tous les objets de tous les calques.
  • logiciel dessin Nouvelle entrée dans le menu zoom : sur tous les objets.
  • Reconnaissance de la clôture automatique de polygones quand le curseur de la souris s'approche du point de départ.
  • Combiner tous les calques en un seul avec un nouveau bouton du dialogue de gestion des calques.
  • Réglage de la taille des points de contrôle dans les préférences.
  • Création des boutons Up/Down des calques pour modifier l'ordre d'affichage de ceux-ci.

  • Version 4.2 Distribuée avec le magazine PC-Compatible en février 2007.
  • logiciel dessin Nouveau « color-picker » en forme de sphère qui tourne sur elle même pour afficher toutes les couleurs de l'arc-en-ciel
  • Dessin de simili-surfaces de révolution, a partir d'un profil constitué de spline.
  • La version 4.0/1 comporte un bug lors des ouvertures consécutives (au moins deux) des fichiers, celui-ci est corrigé.
  • Test de l'export de Denis-Draw au format autodesk (DXF) vers Google-SketchUp qui importe ce format : ok
  • Parcours amélioré de la sélection avec la touche tabulation, seul les objets visibles sont activés.
  • Correction de la projection circulaire haut-bas pour tenir compte de la chasse des caractères.
  • Correction du dessin des tangentes pour les polylines issues des caractères.
  • Reconnaissance et dessin du symbole des angles droits sur les polylines (segments consécutifs)
  • Modification du bouton exclamation pour une mini-rosace couleur logiciel dessin.
  • Modification du bouton arobas pour un signe plus en couleur qui ouvre la palette logiciel dessin.
  • Modification du bouton interrogation par une miniature du diagramme CIE : logiciel dessin.
  • Une seule unité de mesure pour les règles et la ligne d'information.
  • Survol des boutons de la palette couleur avec un curseur réactif.
  • Ajout d'un bouton pour changer l'unité de mesure des règles: centimètre, pouce et Mètre au 1/200ème.
  • Ouverture de la palette couleur avec le bouton plus logiciel dessin.
  • Déplacement et introduction de la palette des boutons dans l'interface.
  • Ajout du dessin des oblongs, à partir de deux segments de lignes.
  • Deux autres options de plus dans les préférences : curseur précis et curseur facile.
  • Deux options de plus dans les préférences, sélection facilitée et cotation une par une.
  • Encadrement de la sélection avec un bord rouge & blanc et curseur spécialisé de déplacement.
  • Test d'impression bitmap et texte sur imprimante HP ok.
  • Ajout d'un bouton R.A.Z. (remise à zéro) dans le dessin des camemberts.
  • Bug à la clôture dans la version 4.1, corrigé par une meilleure allocation du segment de la stack à la place du segment heap!
  • Changement de l'image dans la documentation de la projection circulaire pour la projection disque.
  • Recherche facilitée des segments les plus proches du clic de la souris avec l'outil flèche.
  • Correction du calcul du rayon de la fonction diviser le cercle et de commentaires dans l'aide.
  • Nouvelle fonction enregistrer comme si... le document avait un autre nom, sa documentation et son icône.
  • Retouche des touches accélérateurs dans la documentation.
  • Précision du nom de la barre tempo pour le calcul des entre-deux et des interpolations.
  • Documentation dans l'aide du dessin des trames, avec des liens des ces fonctions vers l'aide.
  • Ajout des nouveautés de Denis-Draw 4 dans l'aide en ligne.
  • Retouche du didacticiel pour afficher des liens vers l'aide html.
  • Menu projection avec la commande escalier et son icône.
  • Ajout bitmap rectangle coloré dans le fichier cadre.dlt. Modification de l'installeur.
  • Correction d'un bug dans l'export html (remplissage des motifs) et ajout de la couleur de la page de fond.
  • "inverser sens" devient deux commandes distinctes : Inversé et sens dans le ruban dynamique.
  • Correction du bug d'affichage de la palette des couleurs dans le dialogue objet.
  • Dessin d'escalier en colimaçon à partir de deux segments de droite.
  • Dessin des axes si un chemin de dessin comporte des quarts de cercle ou si un cercle est sélectionné, suppression des segments en double.
  • Création d'un dialogue d'ouverture des fichiers avec des noms longs pour être compatible avec l'émulateur linux : il est super rapide..
  • Une entrée de plus dans le menu édition pour sélectionner ce qui se trouve inclu avec la sélection.
  • Une autre possibilité pour faire des dégradés avec la fonction interpoline si un polygone et des segments de droite sont sélectionnés.
  • Le tramage des images avec des cercles, des carrés, des losanges; monochrome ou couleur. Possibilité d'appliquer des effets de transformation et d'exporter en postscript.
  • Dans le menu édition, une liste décrivant le nom des actions pour revenir sur celle-ci. Une marque (v) à gauche de la liste indique la position actuelle dans cette liste.
  • Une option de plus dans le paramètrage de l'outil cercle, pour dessiner les quartiers de la lune.

  • Nouveautés de Denis 4.0/1 distribution dans Pc-Compatible Magazine en octobre .Maintenant le code source se compose de plus de 3.000.000 signes ASCII, ou encore plus de 100.000 lignes, et plus de 5.000 méthodes.
  • Suite des finitions de la version 4.0
  • deux entrées de plus dans le menu édition : Sélectionner avec la sélection d'autres éléments et inverser la sélection.
  • Écriture de Méta-tags dans l'export Internet.
  • Tri des caractères accentués dans la liste de clip-art.
  • Implémentation d'un ruban dynamique qui permet d'assister visuellement l'utilisation.
  • Découverte d'un bug et correction sur la fonction symétrie.
  • Des informations supplémentaires sur l'export postscript.
  • Dessin de camembert à partir d'un cercle et dimensionnement des secteurs en degré ou en pourcentage.
  • D'autres effets de tracé sur les courbes spline : maillon, rubalise et collier.
  • Dessin des tangentes si la sélection est une courbe qui comporte des points de spline.
  • Insertion dans l'archive disponible en téléchargement du didacticiel version 0.1.
  • Un tableau de synthèse des objets avec la dénomination, les coordonnées et la couleur.
  • Une option de plus avec l'outil cercle : le dessin de demi-sphère avec éclairage de phong.
  • Après le dessin des connecteurs, trois options pour ceci : droit, oblique ou courbe.
  • Fonction de répétition avec retour et décalage d'un chemin de dessin.
  • Avec le dessin d'un cercle, une option de dessin de spirale.
  • D'autres extrémités, dans le dialogue cotation : prise de terre et connections mâle et femelle.
  • Option supplémentaire pour l'outil ligne afin de dessiner des connecteurs, cliquer sur l'icône suivante ou cliquer avec le bouton droit de la souris sur l'outil ligne.
  • Option d'alignement à touche-touche des éléments de dessin de façon à concevoir rapidement des organigrammes.
  • Plus d'options dans le menu de création des guides: Sur les blocs, sur les points de contrôles ou bien espacés régulièrement.
  • Dessin de cordelettes paramètrables si un chemin de dessin est sélectionné.
  • Dessin de formes cycliques à partir d'un arc de cercle dans le menu adaptatif.
  • Cotation des angles des polygones ou d'une suite de segments de droite.
  • Actualisation du fichier d'aide de la version 4 de Denis.
  • Des nouvelles commandes dans le menu PopUp.
  • Un nouveau menu de projection polygonale: circulaire, cylindrique, cadran, sphérique, sinusoïdale, interpolation...
  • Amélioration du dialogue de dessin des ombres avec la case sinusoïdale.
  • Extraction des images DIB dans les fichiers VML et ajout d'une icône correspondant à cette commande.
  • Ouverture des fichiers images selon les formats suivants : .bmp, .jpg, .gif, .png, .tif
  • Reconnaissance et intégration du postscript pour les imprimantes qui reconnaissent ce protocole dans le dialogue d'impression.
  • Correction du bogue de clôture de l'applicatif avec certaines version de XP.
  • Ajout du dessin de cercle, boussole, cadran à partir d'un segment de ligne.
  • Une nouvelle entrée dans le menu des options: le choix d'un thème de couleur pour agrémenter selon ses goûts ce logiciel, avec une option aléatoire.
  • Création d'image miniature pour afficher les images DIB quand elles sont réduites.
  • Dessin de plein et de délié, ajustement par curseurs de l'enveloppe qui est rectiligne ou curviligne.
  • Dessin de flocons de Van Koch avec le menu popup si la sélection contient un ou des segment(s).
  • Conversion des rectangles à coins arrondis en panneau de stop (hexagone).
  • Précision sur l'objet sélectionné dans le dialogue information.
  • Ajout du code de la couleur au format html dans le dialogue palette.
  • Indication du temps d'affichage après appui sur la touche espace en milliseconde.
  • Roue chromatique plus précise.
  • Dégradé avec plus de couleurs intermédiaires.
  • Paramètrage de l'outil de dessin de cercle et d'ellipse, possibilité de cercle concentrique et de dessin dans le style ORTF.
  • Ajustement variable des couleurs dans le dialogue de dégradé de forme.
  • Conversion des arcs de cercle, des ellipses ou cercles et des rectangles à coins arrondis en éléments de contrôle Bézier.
  • Ajout dans l'outil rectangle du dessin de boîte pointue.
  • Correction du bug de l'orientation de page quand on choisi le mode surface d'impression.
  • Correction orthographique du fichier d'aide contextuel Denis.hlp et intégration dans l'archive.
  • Ajustement de la sélection sur le centre horizontal ou vertical de la page.
  • Insertion de symboles sur le centre des lignes : cercle, rectangle, boîte pointue, boîte à coins arrondis.
  • Export ASCII des fichiers "*.teo" qui devient donc lisible et public avec l'extension ".ato".
  • Nouveau dialogue de création de tableau dans le menu modifier
  • Effet d'affichage de lumière sur les contours
  • Ajout de la longueur d'une ligne dans le dialogue information
  • Ajout d'une flèche pour indiquer le sens de tracé d'un chemin de dessin sélectionné
  • Continuer un chemin de dessin en symétrie horizontale ou verticale.
  • Ajout de la rotation autour de l'axe Y et aussi autour de l'axe X, réglage de la perspective (de 1 a 15°) dans un dialogue accessible avec le bouton droit. Ceci pour dessiner des trapèzes par exemple, l'effet de profondeur du générique de StarWars; J'appelle cela le tangage et le roulis.
  • Dessin de bordure laser autour des objets texte et dessin (épaisseur, couleur) "Menu Attribut Dessin".
  • Dessin de reliefs en perspective (couleurs, distance, direction "Menu Attributs Relief".
  • Dessin d'Ombre (progressive, colorée, éloignement, direction) "Menu Attributs Ombre".
  • Ajout du dialogue Couleurs Laser dans la palette des couleurs (en bas à gauche).
  • Ajout du dialogue Couleurs CIE dans la palette des couleurs (en bas à gauche).
  • Export en postscript des textes ou dessins en perspectives.
  • Ajout de l'export VML pour être compatible avec Internet Explorer.
  • Dessin de losange avec l'outil de dessin de rectangle.
  • Dessin de disque et de tore translucide avec l'outil cercle.
  • Correction de l'appel de l'aide contextuelle (F1).
  • Correction des commandes Références et chercher du menu Fichier.